WordPress Plugin Typebot 1.4.3 Exploit, Stored Cross Site Scripting (XSS) (Authenticated)

# Exploit Title: WordPress Plugin Typebot 1.4.3 - Stored Cross Site Scripting (XSS) (Authenticated)
# Date: 29/11/2021
# Exploit Author: Mansi Singh
# Vendor Homepage: https://wordpress.org/plugins/typebot/
# Software Link: https://wordpress.org/plugins/typebot/
# Tested on Windows
# Reference: https://wpscan.com/vulnerability/2bde2030-2dfe-4dd3-afc1-36f7031a91ea

How to reproduce vulnerability:

1. Install Latest WordPress

2. Install and activate Typebot Version 1.4.3

3. Navigate to Typebot setting >> enter the payload into 'Publish ID or Full URL'.

4. Enter JavaScript payload which is mentioned below
"><img src=x onerror=confirm(1)>

5. You will observe that the payload successfully got stored into the database and when you are triggering the same functionality at that time JavaScript payload gets executed successfully and we'll get a pop-up.

All rights reserved nPulse.net 2009 - 2022
Powered by: MVCP 2.0-RC / BVCP / ASPF-MILTER / PHP 7.4 / NGINX / FreeBSD